Macros

Macros are advanced features that can speed up editing or formatting you may perform often in a Word document. They record sequences of menu selections so that a series of actions can be completed in one step.

Recording A Macro

To record a macro, follow these steps:

  1. Select Tools > Macro > Record New Macro on the menu bar.
    [Record Macro window]
  2. Name the macro in the Macro name field. This name cannot contain spaces and or begin with a number.
  3. From the Store macro in box, select the document you would like the macro to be associated with or choose "All Documents" be able to use the macro in any document.
  4. Enter a description of the macro in the Description field. This is for your reference only, so you remember what the macro does.
  5. Click OK to begin recording. The recording toolbar will allow you to stop, pause, and resume recording.
    [Macro toolbar]
  6. Select actions as normal from the menu bar or toolbars and Word will record the options you choose from the dialog boxes, such as changing the margins on the Page Setup dialog. Word will not record toggling actions, such as View > Toolbars, that have no effect on the document itself.
  7. Click the Stop button the recording toolbar. The macro is now saved.

Running A Macro

To run an existing macro, follow these steps.

  1. Select Tools > Macro > Macros from the menu bar.
  2. From the Macros window, highlight the Macro name in the list and click Run.
    [Macros dialog box]
  3. If the macro is long and you want to stop it while it is running, you can "break" the macro by pressing on the keyboard.
Share this page Share